All transactions have been successfully resent and the issue is resolved.
Posted Apr 28, 2025 - 21:59 EDT
Update
We have now successfully resent all critical transactions and are continuing to resend delayed functional acknowledgments.
Posted Apr 28, 2025 - 17:48 EDT
Update
The team is continuing to resend transactions that were delayed.
Posted Apr 28, 2025 - 13:03 EDT
Monitoring
TrueCommerce experienced a technical issue following our monthly security and software maintenance event that resulted in latency processing a subset of transactions on the network. Not all customers or transactions were impacted.
The issue started at 2:00 a.m. ET on Sunday, April 27th and the issue was identified and confirmed resolved at 7:30 a.m. ET on Monday April 28th. All impacted transactions are being reprocessed and our technical team is monitoring to confirm successful reprocessing. Out of an abundance of caution, TrueCommerce recommends validating for duplicate transactions.
Posted Apr 28, 2025 - 10:27 EDT
This incident affected: Foundry Applications (Transaction Manager) and Trading Network (TrueCommerce AS2, TrueCommerce Internal FTP).