This incident has been resolved on 4/29 at of 1:30 Est .
Posted Apr 30, 2025 - 11:47 EDT
Update
Access to TrueCommerce Foundry has been restored. The team will continue to monitor.
Posted Apr 29, 2025 - 13:49 EDT
Update
We're still experiencing issues accessing TrueCommerce Foundry. The technology team is actively investigating.
Posted Apr 29, 2025 - 13:35 EDT
Monitoring
A fix has been implemented by a third party technology vendor at 12:15 Est and the team is monitoring the performance of the application.
Posted Apr 29, 2025 - 12:42 EDT
Identified
The TrueCommerce technology team continues to work with are third party provider on the issue.
Posted Apr 29, 2025 - 12:10 EDT
Investigating
We are currently experiencing an intermittent issue with access to Foundry applications after login. Users may experience delay loading the transactions page or receive an error message. The TrueCommerce technology team is currently investigating.
Posted Apr 29, 2025 - 11:40 EDT
This incident affected: Foundry Applications (Transaction Manager).