Issue: TrueCommerce Foundry Intermittent Access

Incident Report for TrueCommerce

Resolved

This incident has been resolved. The issue occurred due to a third party VPN issue.
Posted Apr 29, 2025 - 09:58 EDT

Investigating

We are currently experiencing an intermittent issue with access to Foundry applications after login. Users may experience delay loading the transactions page or receive an error message. The TrueCommerce technology team is currently investigating.
Posted Apr 29, 2025 - 09:44 EDT
This incident affected: Foundry Applications (Transaction Manager).