Scheduled Maintenance Window Extended

Incident Report for TrueCommerce

Resolved

Maintenance is complete, and transaction processing applications are operational.
Posted Jun 15, 2025 - 08:36 EDT

Update

The team is continuing to monitor network and platform stability. Transactions are processing successfully, and TrueCommerce applications remain available.
Posted Jun 15, 2025 - 08:04 EDT

Monitoring

TrueCommerce application access is now available, and the team is actively testing and monitoring network transaction processing. Ongoing monitoring will continue to ensure full system stability.
Posted Jun 15, 2025 - 07:16 EDT

Update

The team is actively working through the data center cutover, and the scheduled maintenance window has been extended to Sunday, June 15th at 7:00 A.M. EST.

We appreciate your continued patience as we work to complete this transition.
Posted Jun 15, 2025 - 05:07 EDT

Identified

The maintenance window has been extended to Sunday June 15th 5:00 AM Est. TrueCommerce network and application remain unavailable during this time We appreciate your patience as the team continues the data center cutover.
Posted Jun 15, 2025 - 04:10 EDT
This incident affected: Foundry Applications (Transaction Manager, Pack & Ship, Data Hub, Unified Commerce Hub, Pulse), Trading Network (TrueCommerce AS2, TrueCommerce Internal FTP, TrueCommerce B2B Trading Network), Channel Integrations (Amazon Marketplace, Shopify, Magento, WooCommerce, Online Marketplaces), and Platform (Integration Mapping Tool, Scheduler).